Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2026 - 14:15 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2026 - 14:00 UTC
Scheduled
Xero is performing scheduled maintenance on their Projects feature this weekend. Customers may experience intermittent slowness when syncing data between Xero and Qualy. Qualy's platform is operating normally.
Posted Jul 31, 2026 - 08:45 UTC
This scheduled maintenance affected: Accounting integrations (Xero).