Card payments may be delayed by a partner issue

Incident Report for Qualy

Resolved

Our payment gateway partner reports this is resolved.
Posted Jul 15, 2026 - 10:00 UTC

Investigating

One of our payment gateway partners is experiencing an issue with Mastercard 3DS authentication that may cause delays or failures for some card payments. Our platform is operating normally, and we are monitoring the situation.
Posted Jul 15, 2026 - 09:08 UTC
This incident affected: Payment acceptance (Card payments).