Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 25, 2025 - 16:00 UTC
Scheduled
Our upstream provider will be performing scheduled maintenance which may cause a temporary impact to some Qualy payment card services.
During this window you may be unable to process new payment cards to our system, and you may experience delays in card transaction status.
The Qualy team will monitor the situation following our provider’s maintenance to minimise any disruption, and we’ll be ready to respond quickly to any issues that arise.
If you have any questions or need help, please don’t hesitate to reach out to the Qualy Support team. We're here to help.
Posted Apr 15, 2025 - 11:07 UTC
This scheduled maintenance affected: Core services (Payments).